PROBLEM with the 1.4 version on Mac

Post Reply
fabio87
Posts: 2
Joined: 11 Oct 2013 12:56

PROBLEM with the 1.4 version on Mac

Post by fabio87 » 17 Nov 2014 12:14

Good morning

I've recently installed the 1.4 version of OpenLCA on my MacBook Pro.

When I try to start the program the following error message appear:

See the log file
/Applications/openLCA.spp/configuration/1416218159614.log.

Did some one had the same problem and know how to fix it?

My OS is OSX version 10.9.5
processor 2.4 GHz Intel Core i5
memory 4 GB 1067 MHz DDR3

Thanks in advance

aciroth
Posts: 725
Joined: 09 May 2010 23:28

Re: PROBLEM with the 1.4 version on Mac

Post by aciroth » 17 Nov 2014 19:40

Basically you need to install the JDK 8, see several other posts here in the forum about it. For the new Yosemite OS (so not your case if I understand correctly), check please here for more detailed instructions:
http://osxdaily.com/2014/10/21/get-java-os-x-yosemite/
Hth,
Andreas

fabio87
Posts: 2
Joined: 11 Oct 2013 12:56

Re: PROBLEM with the 1.4 version on Mac

Post by fabio87 » 18 Nov 2014 14:10

Thank you Andreas
Now the program is working

Nellyb
Posts: 2
Joined: 18 Aug 2015 12:04

Re: PROBLEM with the 1.4 version on Mac

Post by Nellyb » 18 Aug 2015 12:13

For those, like me, who are a bit n00by, Java comes in two flavours: JRE & JDK (runtime environment and developer kit). OpenLCA needs JDK, NOT JRE.

To get JDK go to http://www.oracle.com/technetwork/java/ ... 33151.html and download and install the file called "jdk-8u51-macosx-x64.dmg" for "Mac OS X x64". That information is included in the link above, but it's buried and the first option (to download Apple's own version) only givers you JRE.

wputman
Posts: 2
Joined: 26 Jan 2018 17:34

Re: PROBLEM with the 1.4 version on Mac

Post by wputman » 26 Jan 2018 17:41

This post does not apply to the newest Macbooks. OpenLCA does not work on the newest Macbook Pro. The latest version of Java SDK is not useful for running OLCA. When you try to install OLCA, you will get the following error:

"To open “openLCA” you need to install the legacy Java SE 6 runtime."

You want legacy Java SE 6 runtime? Too bad. From the Oracle website:

"Java SE 6 released after April 2013 are only available to Oracle Customers through My Oracle Support (requires support login)."

Please address this issue.

aciroth
Posts: 725
Joined: 09 May 2010 23:28

Re: PROBLEM with the 1.4 version on Mac

Post by aciroth » 26 Jan 2018 18:42

Hi,
This post does not apply to the newest Macbooks
indeed, this post refers to version 1.4 and is from 2015. With newer Macs, the issue is that openLCA uses Java 1.8 and newer Macs only foresee Java 1.9 or Java 1.6 and basically do not allow to use other versions. We are working on this but it will not be an easy and quick fix. I hope you understand.
Andreas

wputman
Posts: 2
Joined: 26 Jan 2018 17:34

Re: PROBLEM with the 1.4 version on Mac

Post by wputman » 26 Jan 2018 20:55

Great, thank you.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest